読者です 読者をやめる 読者になる 読者になる

koogawa log

iOS、Android、foursquareに関する話題

foursquare API利用時に v=YYYYMMDD 指定が必須になっています #4sqdevjp

こちらの記事にも書いた通り、2014年1月28日より foursquare API にアクセスする際に、バージョンパラメータ v=YYYYMMDD の指定が必須になっています。

今後、このパラメータが無い場合は

{
    "meta": {
        "code": 410, 
        "errorDetail": "The Foursquare API no longer supports requests that do not pass in a version parameter. For more details see https://developer.foursquare.com/overview/versioning", 
        "errorType": "param_error"
    }, 
    "response": {}
}

エラーが返ります。

Twitterなどを見ていると、1月29日あたりから「foursquare APIが使えなくなった!」という声が多く見られるようになりました。この原因は、上記の仕様変更によるものだと思われます。

解決するには

APIを叩く際、次のように v=YYYYMMDD パラメータを付加するだけです。

https://api.foursquare.com/v2/venues/search?ll=35.6662026,139.7312591&client_id=FOO&client_secret=BAR&v=20140208

foursquare APIは、YYYYMMDD で指定した日付時点の仕様で動作します。詳しくはバージョンパラメータのドキュメントをご覧ください。

foursquare関連の記事