読者です 読者をやめる 読者になる 読者になる

koogawa log

iOS、Android、foursquareに関する話題

foursquare API利用時、バージョンパラメータの指定が必須に

foursquare API

foursquare からこんなアナウンスが出てました。

2014年1月28日より、foursquare APIにアクセスする際に、バージョンパラメータ v=YYYYMMDD の指定が必須になるそうです*1。それ以降、このパラメータの指定がない場合はエラーが返るようです。

この準備段階として、1月7日の16:00-17:00に「brownout test」が実査される予定です。テスト中は、v パラメータが無いリクエストはすべて 400 エラーが返却されます。

また、2014年の早い段階*220120609 以前のサポートが打ち切られるようです。2012年6月9日と言えば、カテゴリアイコンがリニューアルされた日ですよね。

つまり、旧デザインのカテゴリアイコンは来年以降、使えなくなるということでしょうか…。

私がリリースしている「Venue Map」(世界中のベニューを地図上で見ることができるアプリ)も、旧アイコンベースで画面が設計されているため、早いうちに対応する必要がありそうです。

Venue Map for foursquare

Venue Map for foursquare

  • Kosuke Ogawa
  • ナビゲーション
  • 無料

fousquare APIを使ったアプリを開発されている方は、一度ソースコードを見直した方がよさそうですね。

ちなみに関係ないですが、この一文(+画像)が個人的にかなり刺さりましたw

Hopefully your reaction is less like this but more like this because of previous warnings we’ve given in API responses.

*1:バージョンパラメータについてはこちら https://developer.foursquare.com/overview/versioning

*2:詳細な日時が決まり次第、公式なアナウンスがあるとのことです。